RV.Net Open Roads Forum: Tech Issues: Water Heater Noise

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Water Heater Noise

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Puddles

Lafayette, Indiana

Senior Member

Joined: 03/17/2003

View Profile


Offline
Posted: 01/30/22 05:29pm Link  |  Quote  |  Print  |  Notify Moderator

Have a 10 gal. Suburan Water... Heater started sounding like a jet when propane came on... flame was way up in the tube. Suggestion was that the regulator was bad, flame shouldn't be up in the tube. Replaced regulator and problem went away for 2 weeks... next time used the heater, back to jet sound and flame up in the tube.. Installed another new propane regulator... Same problem the first time heater came on??? Any suggestions appreciated.


HTML

bgum

South Louisiana

Senior Member

Joined: 02/22/2006

View Profile


Offline
Posted: 01/31/22 10:49am Link  |  Quote  |  Print  |  Notify Moderator

Adjust the air to less going into the burner. Should be a blue flame and some orange is ok.OK.

You may want to have a garage sale on regulators.

naturist

Lynchburg, VA

Senior Member

Joined: 04/24/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 01/31/22 01:18pm Link  |  Quote  |  Print  |  Notify Moderator

Last time I had that very problem, it was due to having the burner tube full of dead stink bugs. Cleaned them out, and all was good.





dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 02/01/22 09:03am Link  |  Quote  |  Print  |  Notify Moderator

bgum wrote:

Adjust the air to less going into the burner. Should be a blue flame and some orange is ok.OK.

You may want to have a garage sale on regulators.


Suburban's do not have an Air adjustment. He needs to clean out the burner flue tube with a brush and also remove the Gas orofice and make sure it has no debris. He also needs to check the LP gas pressure. Doug

Puddles

Lafayette, Indiana

Senior Member

Joined: 03/17/2003

View Profile


Offline
Posted: 02/02/22 10:29am Link  |  Quote  |  Print  |  Notify Moderator

Problem solved. Big end of burner tube was rusted off... no baffle left. New tube fixed problem.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Water Heater Noise
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.