RV.Net Open Roads Forum: Fifth-Wheels: Landing Gear stoped working

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Fifth-Wheels

Open Roads Forum  >  Fifth-Wheels

 > Landing Gear stoped working

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Gray Fox

Swansea Ma. USA

Senior Member

Joined: 04/14/2003

View Profile



Good Sam RV Club Member

Offline
Posted: 04/13/22 05:28pm Link  |  Quote  |  Print  |  Notify Moderator

I'm looking for some HitchHiker friends I HAVE A problem with the landing legs they stopped working. It may be the fuse but were is the fuse box for the legs. It's a 2009 HitchHiker L S .


Gray Fox
2014 F350 4x4 Diesel Lariat
2009 HitchHiker-LS 34.5 RLTG
Always keep moving so you don't seize up.


cummins2014

Utah

Senior Member

Joined: 02/20/2008

View Profile



Good Sam RV Club Member

Offline
Posted: 04/14/22 07:47am Link  |  Quote  |  Print  |  Notify Moderator

Gray Fox wrote:

I'm looking for some HitchHiker friends I HAVE A problem with the landing legs they stopped working. It may be the fuse but were is the fuse box for the legs. It's a 2009 HitchHiker L S .



Should be on the hot lead or red wire going to the landing gear motor , more than likely 30 amp inline fuse .

padredw

East Texas

Senior Member

Joined: 08/11/2013

View Profile



Good Sam RV Club Member

Offline
Posted: 04/14/22 12:37pm Link  |  Quote  |  Print  |  Notify Moderator

Are you familiar with the NwWa Owners Forum? Someone there can surely help you. NuWa Owners Forum

I have a 2007 HitchHiker II but have never had a problem with the landing legs. There are two locations of fuses:

1> under the "nose" of the trailer where the umbilical cord comes into the trailer. There is a "lid" which opens and a cover which must be removed, BUT I do not think there is a fuse for the landing legs there, just running lights, brakes, turn signals, etc.

2> Inside the trailer there is the main fuse block under the cover of the power control center there are both AC breakers and DC fuses.





Gray Fox

Swansea Ma. USA

Senior Member

Joined: 04/14/2003

View Profile



Good Sam RV Club Member

Offline
Posted: 04/14/22 06:57pm Link  |  Quote  |  Print  |  Notify Moderator

I found the fuse Ive been looking for it's in the battery
compartment, an it only had a 25 instead of 30 amp. Thanks for your
help.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Fifth-Wheels

 > Landing Gear stoped working
Search:   Advanced Search

Search only in Fifth-Wheels


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.