RV.Net Open Roads Forum: Class A Motorhomes: Breaker issues

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Breaker issues

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Tuckerman52

Lafayette.la

New Member

Joined: 04/01/2022

View Profile


Offline
Posted: 07/04/22 06:03pm Link  |  Print  |  Notify Moderator

In reference to my previous post I also have a 12-3 extension cord coming to run from my 110 to the plug-in in the motorhome that may help I'm not sure but both of my rooftop Ac. Should only pull about 25 amps together that should leave me plenty to run that room AC I'm going to try the larger extension cord and I'm going to also have a 50 amp breaker installed in my house panel and run a remote plug so I can plug the 50 amp on my motorhome in thanks again for any help

This Topic Is Closed  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Class A Motorhomes  >  General Topics

 > Breaker issues
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.