RV.Net Open Roads Forum: Tech Issues: Trailer brakes not working

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Posting Help and Support  |  Contact  

Search:   Advanced Search

Search only in Tech Issues

Open Roads Forum  >  Tech Issues

 > Trailer brakes not working

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Sponsored By:
Carlotta14

ontario canada

New Member

Joined: 11/21/2022

View Profile


Offline
Posted: 11/21/22 07:42am Link  |  Quote  |  Print  |  Notify Moderator

Hey , I installed a pair of elec brakes on my old trailer, left and right ! . After instal, when jacked still, testing, brake controller in truck stopped wheel from turning, but not foot pedal. No codes, 2016 sierra HD. when on the road, no diff. Chnged the 30 amp fuse. The dash says the gain is rising when pushing the pedal, but the wheels don't seem to be slowing ( I can usually feel when they are active) . When I hooked the wires up, i left about 4 inches of the old brake wire and hooked to that, should I have removed this section ? There was not a lot of wiggle room in the wheel well ! Thanks for any hep. M

2112

Texas

Senior Member

Joined: 07/16/2011

View Profile



Posted: 11/21/22 08:10am Link  |  Quote  |  Print  |  Notify Moderator

The controller only applies power to the brakes by pressing the brake pedal when the truck is moving. The manual slide always applies power when used.

The reason being is you don't want/need current flowing through your trailer brake coils while sitting at a long red light with your foot on the brake.

Tow it around the block to verify the controller is working properly when pressing the brake pedal.


2011 Ford F-150 EcoBoost SuperCab Max Tow, 2084# Payload, 11,300# Tow,
Timbrens, PullRite SuperGlide 2700 15K
2013 KZ Durango 2857


MFL

Midwest

Senior Member

Joined: 11/28/2012

View Profile



Good Sam RV Club Member

Offline
Posted: 11/21/22 09:11am Link  |  Quote  |  Print  |  Notify Moderator

^2112 is correct.

Yes, best way to test, is to tow it. Most trucks with IBC will give a starting point for gain set. Mine states 6 of 10, for starting point. Now drive on pavement, where you can safely slide manual control lever full on, at say 25 mph. Most controllers, set properly, will just keep from locking the trailer brakes, and sliding the tires.

Jerry





joelc

Cedar Point, NC

Senior Member

Joined: 02/23/2004

View Profile


Offline
Posted: 11/21/22 11:39am Link  |  Quote  |  Print  |  Notify Moderator

Jack up your trailer, have someone spin the wheels and then apply the break. It should stop the wheel. If this does not work you have a wired problem.

Boon Docker

Mountain Foothills of Southern Alberta

Senior Member

Joined: 10/30/2015

View Profile



Posted: 11/21/22 02:19pm Link  |  Quote  |  Print  |  Notify Moderator

What is the make and model of the controller?
Sounds like a Proportional controller that is not calibrated.

katysdad

Virginia

Senior Member

Joined: 08/03/2010

View Profile



Posted: 11/21/22 05:05pm Link  |  Quote  |  Print  |  Notify Moderator

Control needs to feel inertia of vehicle slowing down to work. Manual lever works anytime. take it for a road test to check for normal operation.


Dodge Ram 3500 DRW Diesel

Boon Docker

Mountain Foothills of Southern Alberta

Senior Member

Joined: 10/30/2015

View Profile



Posted: 11/21/22 06:45pm Link  |  Quote  |  Print  |  Notify Moderator

The OP said "...when on the road, no diff." ,so I presume that a road test was already tried.
Inertia based controllers need movement to operate properly, timed based controller do not need movement.

JBarca

Radnor, Ohio, USA

Senior Member

Joined: 12/16/2004

View Profile





Offline
Posted: 11/21/22 10:01pm Link  |  Quote  |  Print  |  Notify Moderator

Carlotta14 wrote:

Hey , I installed a pair of elec brakes on my old trailer, left and right ! . After instal, when jacked still, testing, brake controller in truck stopped wheel from turning, but not foot pedal. No codes, 2016 sierra HD. when on the road, no diff. Chnged the 30 amp fuse. The dash says the gain is rising when pushing the pedal, but the wheels don't seem to be slowing ( I can usually feel when they are active) . When I hooked the wires up, i left about 4 inches of the old brake wire and hooked to that, should I have removed this section ? There was not a lot of wiggle room in the wheel well ! Thanks for any hep. M


The way you are testing the system may be part of the problem. If the camper is off the ground, you spin the wheel, press the manual button on the brake controller and the wheels stop, OK that at least tells you the brake coils are getting some power. But it does not take much power to stop a wheel off the ground.

When you are towing the camper, say at 20 mph down a empty road, if you press only the manual button hard, does it slow the camper at all? There are no truck brakes in this test, you are testing the mechanics of the brakes and the wire from the controller. If you do not get some braking feel in this test, then there can be a mechanical issue or a wire issue not able to deliver enough current. Did you adjust the brakes and if so, what was the feel you where after in adjusting them?

Did you burnish in the brakes yet? You may not have, but it will need to be done before good braking will happen.

You need to sort out, is the trailer brakes correct, and then add in the truck brake pedal test.

You can also do a drag test. Unhook the 7 wire cable from the truck so you do not back feed the brake controller with camper electric. Pull the emergency breakaway switch, drive real slow forward, you should have brake lock up or a really hard drag. If this does not work, you have to back into why? This then points to the trailer has an issue. This test also assumes the break away switch is working. When the switches get old, they have been know to not work, corrosion in the switch stops current from passing and creates a lot of heat in the switch. Point, if the drag test does not work, make sure the breakaway switch is passing 12 amps if you have 4 wheels braking.

Hope this helps

John


John & Cindy

2005 Ford F350 Super Duty, 4x4; 6.8L V10 with 4.10
CC, SB, Lariat & FX4 package
21,000 GCWR, 11,000 GVWR
Ford Tow Command
1,700# Reese HP hitch & HP Dual Cam
2 1/2" Towbeast Receiver

2004 Sunline Solaris T310SR
(I wish we were camping!)


Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 

Open Roads Forum  >  Tech Issues

 > Trailer brakes not working
Search:   Advanced Search

Search only in Tech Issues


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:




© 2022 CWI, Inc. © 2022 Good Sam Enterprises, LLC. All Rights Reserved.