RV.Net Open Roads Forum: Class A Motorhomes: A/C humming

RV Blog

  |  

RV Sales

  |  

Campgrounds

  |  

RV Parks

  |  

RV Club

  |  

RV Buyers Guide

  |  

Roadside Assistance

  |  

Extended Service Plan

  |  

RV Travel Assistance

  |  

RV Credit Card

  |  

RV Loans

Open Roads Forum Already a member? Login here.   If not, Register Today!  |  Help

Newest  |  Active  |  Popular  |  RVing FAQ Forum Rules  |  Forum Help and Support  |  Contact

Search:   Advanced Search

Search only in Class A Motorhomes

Open Roads Forum  >  Class A Motorhomes  >  All

 > A/C humming

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next
Sponsored By:
bluebarry1964b

Homestead, Florida

Senior Member

Joined: 10/22/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 08/11/12 04:07am Link  |  Quote  |  Print  |  Notify Moderator

I have a Duo-Therm (Domestic) rooftop airconditioner. Tonight it has started to make a deep humming sound. It is still blowing cold air just fine, but the weird thing is that when I try to shut off the a/c unit at the thermostat, the unit stops blowing air, but doesn't shut off. I still hear this deep humming sound as if something is still turned on in the a/c unit. I'm having to shut the breaker off at the breaker box in order to get the a/c unit to shut off completely & stop the humming sound.
Has anyone else experienced this, and if so, what is it, and what is the solution? Thanks.

Ranger Smith

Wherever the rig is parked

Senior Member

Joined: 05/13/2006

View Profile





Offline
Posted: 08/11/12 05:26am Link  |  Quote  |  Print  |  Notify Moderator

It is your control board on the AC that is bad. Mine did the same thing. Fan is shutting off but compressor is staying on.


Where I Am Now

Amateur Radio Operator KK9W ARRL VE FT DX2000

Steve
1999 Winnebago Ultimate Freedom
2011 RAM 1500 Laramie CC 4x4
Cooper . . . The Aussie-Doodle


dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 08/11/12 06:28am Link  |  Quote  |  Print  |  Notify Moderator

You need a 5 button Dometic CCC AC control board. The Compresor relay on the board is stuck and the relay is NOT a seperate part. Doug

barnaclebill

Atlanta Michigan or towards the sun

Senior Member

Joined: 03/09/2005

View Profile



Posted: 08/11/12 07:22am Link  |  Quote  |  Print  |  Notify Moderator

Doug, mine does the same thing, it is a penguin with heat pump, but if I shut off at the breaker and turn it back on after 10-15 minutes it runs fine, cycles on and off but then will do the same thing again maybe 1-2-3 days later. Any thoughts? Thanks, Bill


2003 41' Newmar Mountain Aire
400 Cummins
Jeep Liberty
Blue Ox Brake Buddy

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 08/11/12 08:49am Link  |  Quote  |  Print  |  Notify Moderator

barnaclebill wrote:

Doug, mine does the same thing, it is a penguin with heat pump, but if I shut off at the breaker and turn it back on after 10-15 minutes it runs fine, cycles on and off but then will do the same thing again maybe 1-2-3 days later. Any thoughts? Thanks, Bill


Same relay and problem. Doug

tropical36

Southwest Florida_USA

Senior Member

Joined: 07/11/2004

View Profile


Offline
Posted: 08/11/12 09:31am Link  |  Quote  |  Print  |  Notify Moderator

Had some issues with our dometic. Story short, after replacing the burnt out fan motor, it still wouldn't run, although the compressor always would. Disconnected the connector from the inside and checked it for burnt contacts or whatever and pulled the 3amp pcb fuse which was OK. reinstalled both and the fan took off????
Have no clue as to why except that it might have reset the control board.
About a year or two ago the old fan motor froze up. Disassembly and some grease on the bearing surfaces cured that problem until now. Did this most recent repair in this campground as I had the new motor on board and so far so good.
As a side note, the fan motor doesn't use a start capacitor and shares the run capacitor with the compressor, so one might want to consider these items in troubleshooting also.


"We are often so caught up in our destination that we forget to appreciate the journey."

1998 36ft. National Tropi-Cal Model 6350 on a 1997 Chevy P32
Chassis_7.4 Vortec Engine_4L80E Tranny_slide_tag axle.

Dinghy_2010 Jeep Wrangler JKU ISLANDER.


barnaclebill

Atlanta Michigan or towards the sun

Senior Member

Joined: 03/09/2005

View Profile



Posted: 08/11/12 10:45am Link  |  Quote  |  Print  |  Notify Moderator

dougrainer wrote:

barnaclebill wrote:

Doug, mine does the same thing, it is a penguin with heat pump, but if I shut off at the breaker and turn it back on after 10-15 minutes it runs fine, cycles on and off but then will do the same thing again maybe 1-2-3 days later. Any thoughts? Thanks, Bill


Same relay and problem. Doug


Thank you for your quick reply, Bill

bluebarry1964b

Homestead, Florida

Senior Member

Joined: 10/22/2011

View Profile



Good Sam RV Club Member

Offline
Posted: 08/11/12 03:27pm Link  |  Quote  |  Print  |  Notify Moderator

Is it the circuit board on the wall thermostat that's no good, or the circuit board in the a/c unit itself?

dougrainer

Carrolton, Texas

Senior Member

Joined: 06/11/2007

View Profile


Offline
Posted: 08/11/12 03:52pm Link  |  Quote  |  Print  |  Notify Moderator

bluebarry1964b wrote:

Is it the circuit board on the wall thermostat that's no good, or the circuit board in the a/c unit itself?


The AC circuit board, NOT the wall tstat. Doug

tropical36

Southwest Florida_USA

Senior Member

Joined: 07/11/2004

View Profile


Offline
Posted: 08/11/12 04:30pm Link  |  Quote  |  Print  |  Notify Moderator

bluebarry1964b wrote:

Is it the circuit board on the wall thermostat that's no good, or the circuit board in the a/c unit itself?

I'm guessing the a/c itself if your compressor is running and what I was referring to with mine.

Reply to Topic  |  Subscribe  |  Print Topic  |  Post New Topic  | 
Page of 3  
Next

Open Roads Forum  >  Class A Motorhomes  >  All

 > A/C humming
Search:   Advanced Search

Search only in Class A Motorhomes


New posts No new posts
Closed, new posts Closed, no new posts
Moved, new posts Moved, no new posts

Adjust text size:

© 2014 RV.Net | Terms & Conditions | PRIVACY POLICY | YOUR PRIVACY RIGHTS